<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-3511135426281664",
enable_page_level_ads: true
});
</script> 
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://thenewswheel.com/xmlrpc.php" />
<!--||  JM Twitter Cards by Julien Maury 11.1.1  ||-->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:creator" content="@thenewswheel">
<meta name="twitter:site" content="@thenewswheel">
<meta property="og:title" content="Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’">
<meta property="og:description" content="Stephen King, killer cars, and lots of substance abuse. What could go wrong? Plenty, as it turns out...Photo: Pxfuel via CCAh, Maximum Overdrive. This delirious, substance-fueled 1986 flick about">
<meta property="og:image" content="https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night.jpg">
<!--||  /JM Twitter Cards by Julien Maury 11.1.1  ||-->
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
var gtm4wp_datalayer_name = "dataLayer";
var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’ - The News Wheel</title>
<meta name="description" content="Remember &#039;Maximum Overdrive,&#039; Stephen King&#039;s coked-up killer-car movie? Here&#039;s what the film&#039;s star, Emilio Estevez, has to say about it." />
<link rel="canonical" href="https://thenewswheel.com/emilio-estevez-hilariously-rips-on-maximum-overdrive/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’ - The News Wheel" />
<meta property="og:description" content="Remember &#039;Maximum Overdrive,&#039; Stephen King&#039;s coked-up killer-car movie? Here&#039;s what the film&#039;s star, Emilio Estevez, has to say about it." />
<meta property="og:url" content="https://thenewswheel.com/emilio-estevez-hilariously-rips-on-maximum-overdrive/" />
<meta property="og:site_name" content="The News Wheel" />
<meta property="article:published_time" content="2021-04-16T20:15:54+00:00" />
<meta property="article:modified_time" content="2021-04-16T20:16:00+00:00" />
<meta property="og:image" content="https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night.jpg" />
<meta property="og:image:width" content="1250" />
<meta property="og:image:height" content="720" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Daniel DiManna">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="2 minutes">
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The News Wheel &raquo; Feed" href="https://thenewswheel.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The News Wheel &raquo; Comments Feed" href="https://thenewswheel.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The News Wheel &raquo; Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’ Comments Feed" href="https://thenewswheel.com/emilio-estevez-hilariously-rips-on-maximum-overdrive/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thenewswheel.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<!-- <link rel='stylesheet' id='wp-block-library-css'  href='https://thenewswheel.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//thenewswheel.com/wp-content/cache/wpfc-minified/ee8g3oy1/6ezv7.css" media="all"/>
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!-- <link rel='stylesheet' id='gabfire-widget-css-css'  href='https://thenewswheel.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=5.7.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='https://thenewswheel.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='bootstrap-css'  href='https://thenewswheel.com/wp-content/themes/patterns/framework/bootstrap/css/bootstrap.css?ver=5.7.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='bootstrap-responsive-css'  href='https://thenewswheel.com/wp-content/themes/patterns/framework/bootstrap/css/bootstrap-responsive.css?ver=5.7.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='gabfire-style-css'  href='https://thenewswheel.com/wp-content/themes/patterns/style.css?ver=5.7.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//thenewswheel.com/wp-content/cache/wpfc-minified/lw0q0s80/6ezv7.css" media="all"/>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=5.7.1' id='jquery-js'></script>
<script src='//thenewswheel.com/wp-content/cache/wpfc-minified/9a1clst8/6ezv7.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/plugins/open-in-new-window-plugin/open_in_new_window_yes.js' id='oinw_vars-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/plugins/open-in-new-window-plugin/open_in_new_window.js' id='oinw_methods-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.6' id='gtm4wp-form-move-tracker-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/framework/bootstrap/js/bootstrap.min.js?ver=5.7.1' id='bootstrap-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/inc/js/jquery.cycle2.min.js?ver=5.7.1' id='cycle2-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/inc/js/jquery.easing.1.3.js?ver=5.7.1' id='easing-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/inc/js/flowplayer/flowplayer.min.js?ver=5.7.1' id='flowplayer-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/inc/js/jquery.tools.min.js?ver=5.7.1' id='jquerytools-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/inc/js/responsive-menu.js?ver=5.7.1' id='responsive-menu-js'></script> -->
<!-- <script type='text/javascript' src='https://thenewswheel.com/wp-content/themes/patterns/inc/js/jquery.ticker.js?ver=5.7.1' id='news-ticker-js'></script> -->
<link rel="https://api.w.org/" href="https://thenewswheel.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thenewswheel.com/wp-json/wp/v2/posts/287577" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thenewswheel.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thenewswheel.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://thenewswheel.com/?p=287577' />
<link rel="alternate" type="application/json+oembed" href="https://thenewswheel.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthenewswheel.com%2Femilio-estevez-hilariously-rips-on-maximum-overdrive%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thenewswheel.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthenewswheel.com%2Femilio-estevez-hilariously-rips-on-maximum-overdrive%2F&#038;format=xml" />
<!-- GA Google Analytics @ https://m0n.co/ga -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-40785325-1', 'auto');
ga('send', 'pageview');
</script>
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-40785325-1', 'auto', {'allowAnchor': true});
__gaTracker('set', 'forceSSL', true);
__gaTracker('require', 'displayfeatures');
__gaTracker('require', 'linkid', 'linkid.js');
__gaTracker('send','pageview');
//ga
</script>
<script type="text/javascript">
var _statcounter = _statcounter || [];
_statcounter.push({"tags": {"author": "ddimanna"}});
</script>
<style type="text/css" media="screen">.menu-item.hide_this_item{ display:none !important; }</style>
<!-- This site is optimized with the Schema plugin v1.7.9.0 - https://schema.press -->
<script type="application/ld+json">{"@context":"https:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/thenewswheel.com\/emilio-estevez-hilariously-rips-on-maximum-overdrive\/"},"url":"https:\/\/thenewswheel.com\/emilio-estevez-hilariously-rips-on-maximum-overdrive\/","headline":"Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’","datePublished":"2021-04-16T16:15:54-04:00","dateModified":"2021-04-16T16:16:00-04:00","publisher":{"@type":"Organization","@id":"https:\/\/thenewswheel.com\/#organization","name":"The News Wheel","logo":{"@type":"ImageObject","url":"https:\/\/thenewswheel.com\/wp-content\/uploads\/2017\/05\/TNW-Logo.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/thenewswheel.com\/wp-content\/uploads\/2021\/04\/scary_truck_at_night.jpg","width":1250,"height":720},"articleSection":"Archives","description":"Stephen King, killer cars, and lots of substance abuse. What could go wrong? Plenty, as it turns out...Photo: Pxfuel via CC Ah, Maximum Overdrive. This delirious, substance-fueled 1986 flick about killer vehicles has truly earned its cult status over the past 35 years. Generally regarded as one of the","author":{"@type":"Person","name":"Daniel DiManna","url":"https:\/\/thenewswheel.com\/author\/ddimanna\/","description":"Daniel DiManna hails from little Sylvania, Ohio. A graduate of Lourdes University with a degree in Fine Arts (which has thus far proven about as useful as a wet paper towel), Daniel’s hobbies\/passions include film history, reading, fiction\/non-fiction writing, sculpting, gaining weight, and adding more toys, posters, books, model kits, DVD’s, screen-used props, and other ephemera to his already shamefully monumental collection of Godzilla\/movie monster memorabilia. His life goals include a return trip to Japan, getting a podcast off the ground, finishing his novel, and yes, buying even more monster toys. See more articles by Daniel.","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/f89576dce5af9a64e2010aead84c6573?s=96&d=mm&r=pg","height":96,"width":96}}}</script>
<!-- Google Webmaster Tools plugin for WordPress -->
<meta name="google-site-verification" content="I4pC-JcvzLNcy4PWUw_ISsoQXi33e71uWvHERyxtHwk" />
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["archives","cars-in-film","laugh-brake"],"pageAttributes":["80s-horror","bad-movie","emilio-estevez","killer-car-movie","maximum-overdrive","so-bad-its-good-movie","stephen-king"],"pagePostAuthor":"Daniel DiManna"};
dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TZB72K5');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><link rel="shortcut icon" href="https://thenewswheel.com/wp-content/uploads/2013/08/news-wheel-favicon.png"/>
<!-- Custom Styling -->
<style type="text/css">
#header {
background: white;
}
#footer{
background: #333;
padding: 5px 0px 0px 0px;
height: auto;
width: 100%;
}
h3.archivename{
font-family: sans-serif;
}
span.entrytag.metaitem.pull-right{
Display: none;
}
div.share-to-pinterest.pull-right{
Display: none;
}
div.share-to-google.pull-right{
Display: none;
}
div.share-to-twitter.pull-right{
Display: none;
}
div.share-to-facebook.pull-right{
Display: none;
}
Div#sidebar.sidebar.sidebar-right{
width: 350px;
}
Div#content{
width: auto;
max-width: 760px;
}
.gallery-row {margin:0 auto}
h2{
padding: 0px 0px 10px 0px !important;
}
h3{
padding: 0px 0px 10px 0px !important;
}
h4{
padding: 0px 0px 10px 0px !important;
}
#bottom_ads {display: none !important;}
#footer li{
display:inline;
}
.span3{
width: 100%;
list-style: none;
}
#footer .widget ul li {
Border-style: none;
}
.widget{
margin-bottom: 0px;
}
#footer a{
color: #ccc;
}
#footer p{
display: inline;
text-align: center;
}
#footer_data{
display: none;
}
#wpadminbar{
display: inline;
}
.footerlink{
padding: 0px 10px 0px 10px;
margin: 0;
}
#foo_widget1{
padding-bottom: 0px;
}
#foo_widget3{
padding-bottom: 0px;
}
div.post_sharebuttons{
display: none;
}
div.post_tools{
display: none;
}
/* visited link */
a:visited {
color: #4d0099;
}
.iframe-container{
position: relative;
width: 100%;
padding-bottom: 56.25%; 
height: 0;
}
.iframe-container iframe{
position: absolute;
top:0;
left: 0;
width: 100%;
height: 100%;
}
.facebook-responsive {
overflow:hidden;
padding-bottom:56.25%;
position:relative;
height:0;
}
.facebook-responsive iframe {
left:0;
top:0;
height:100%;
width:100%;
position:absolute;
}
a img, a:hover img{
border: none !important;
background: transparent !important
}
.entry img{
border: none !important;
background: transparent !important
}
/* ----- CENTER CAPTION OF PHOTO WIDGET----- */
.wp-block-image figcaption {
text-align: center;
}
/* END CENTER CAPTION OF PHOTO WIDGET */
/* ----- CENTER CAPTION OF PHOTO/SLIDESHOW WDIGET----- */
.wp-block-jetpack-slideshow .wp-block-jetpack-slideshow_caption.gallery-caption {
text-align: center;
}
/* END CENTER CAPTION OF SLIDESHOW */</style>
<script type='text/javascript'>
<!--	
(function($){
$.fn.jfontsize = function(opcoes) {
var $this=$(this);
var defaults = {
btnMinusClasseId: '.fontSizeMinus',
btnPlusClasseId: '.fontSizePlus',
btnMinusMaxHits: 5,
btnPlusMaxHits: 5,
sizeChange: 1
};
if(($.isArray(opcoes))||(!opcoes)){
opcoes = $.extend(defaults, opcoes);
} else {
defaults.sizeChange = opcoes;
opcoes = defaults;
}
var limite=new Array();
var fontsize_padrao=new Array();
$(this).each(function(i){
limite[i]=0;
fontsize_padrao[i];
})
$('.fontSizeMinus, .fontSizePlus').removeAttr('href');
$('.fontSizeMinus, .fontSizePlus').css('cursor', 'pointer');
/* A- */
$('.fontSizeMinus').click(function(){
$this.each(function(i){
if (limite[i]>(-(opcoes.btnMinusMaxHits))){
fontsize_padrao[i]=$(this).css('font-size');
fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
fontsize=$(this).css('font-size');
fontsize=parseInt(fontsize.replace('px', ''));
fontsize=fontsize-(opcoes.sizeChange);
fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
limite[i]--;
$(this).css('font-size', fontsize+'px');
}
})
})
/* A+ */
$('.fontSizePlus').click(function(){
$this.each(function(i){
if (limite[i]<opcoes.btnPlusMaxHits){
fontsize_padrao[i]=$(this).css('font-size');
fontsize_padrao[i]=fontsize_padrao[i].replace('px', '');
fontsize=$(this).css('font-size');
fontsize=parseInt(fontsize.replace('px', ''));
fontsize=fontsize+opcoes.sizeChange;
fontsize_padrao[i]=fontsize_padrao[i]-(limite[i]*opcoes.sizeChange);
limite[i]++;
$(this).css('font-size', fontsize+'px');
}
})
})
};
})(jQuery);	
(function($) {
$(document).ready(function() {
$(".children").parent("li").addClass("has-child-menu");
$(".sub-menu").parent("li").addClass("has-child-menu");
$(".drop").parent("li").addClass("has-child-menu");
$('.entry p').jfontsize();
$('#js-news').ticker({
speed: 0.10,
fadeInSpeed: 600,
controls: false, 
direction: 'ltr',
titleText: ''
});	
$('a[href=#top]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });
$("ul.tabs").tabs("div.panes > div");
$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
// Responsive Menu (TinyNav)
$(".menu").tinyNav({
active: 'current_page_item', // Set the "active" class for default menu
label: ''
});
$(".tinynav").selectbox();
});
})(jQuery);
// -->
</script>
<link rel="amphtml" href="https://thenewswheel.com/emilio-estevez-hilariously-rips-on-maximum-overdrive/amp/">		<style type="text/css" id="wp-custom-css">
/*
Welcome to Custom CSS!
To learn how this works, see http://wp.me/PEmnE-Bt
*/
div#header>div#logo-and-search>div.sitelogo {
float: none !important;
width: 75% !important;
margin: 0 auto !important;
}
.mainnav li.current_page_item a, .mainnav li.current-cat a, .mainnav li.current-menu-item a, .mainnav li.current-cat-parent a, .mainnav li a:hover {
background-color: #a3bf4e
}
.mainnav li a {
font-weight: bold;
}		</style>
<!-- HTML5 shim, for IE6-8 support of HTML5 elements -->
<!--[if lt IE 9]>
<script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<link rel="stylesheet" type="text/css" media="screen" title="Stylesheet" href="https://thenewswheel.com/wp-content/themes/patterns/css/ie-lt9.css" />
<![endif]-->
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/thenewswheel-network/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script> 
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-287577 single-format-standard">
<div class="container">
<div class="row">	
<div id="header" class="span12">
<div id="masthead">
<div class="masthead_left">
</div><!-- masthead_left -->
<div class="clearfix"></div>
</div>	
<div id="logo-and-search">
<div class="sitelogo" style="padding:15px 0px 15px 0px;">	
<h1>
<a href="https://thenewswheel.com/" title="We Wheely Like Cars!">
<img src="https://thenewswheel.com/wp-content/uploads/2016/08/NewsWheel-Header-8-25-16.jpg" alt="The News Wheel" title="The News Wheel"/>
</a>
</h1>
</div><!-- .logo -->
<div class="header-right">
<div id="search">
<form class="gab_search_style1" action="https://thenewswheel.com/">
<fieldset>
<input type="text" id="s" class="text" name="s" value="Search in site..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;"/>
<input type="image" class="submit_style1" src="https://thenewswheel.com/wp-content/themes/patterns/framework/images/bgr_search_box-submit.png" alt="Search" /> 
</fieldset>
</form>						</div><!-- /search -->
<div id="social_header">
<ul>
<li><a class="gab_twitter masthead_social" href="https://twitter.com/thenewswheel" rel="nofollow" title="Follow on Twitter">Twitter</a></li>
<li><a class="gab_facebook masthead_social" href="https://www.facebook.com/newswheel" rel="nofollow" title="Connect on Facebook">Facebook</a></li>
<li><a class="gab_linkedin masthead_social" href="https://instagram.com/thenewswheel/" rel="nofollow" title="Follow on Instagram">LinkedIn</a></li>
<li><a class="gab_ytube masthead_social" href="https://www.youtube.com/channel/UCPymFEdj4D61OKEEjezgjkg" rel="nofollow" title="Watch on Youtube">Youtube</a></li>
<li><a class="gab_email masthead_social" href="http://thenewswheel.us10.list-manage.com/subscribe?u=4007d4f692c54bef3af3fecc3&id=b1ccb8a612" rel="nofollow" title="Subscribe to latest posts via email">Email</a></li>
<li><a class="gab_rss masthead_social" href="https://thenewswheel.com/feed/" rel="nofollow" title="Subscribe to latest posts in RSS">RSS</a></li>
</ul>
</div>
</div>
</div><!-- #logo-and-search -->
<div id="mainmenu">
<ul class="mainnav menu">
<li class="first"><a href="https://thenewswheel.com/" title="We Wheely Like Cars!"><i class="icon-home nav-icon"></i>Home</a></li>
<li id="menu-item-131908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131908"><a href="https://thenewswheel.com/car-news-by-brand/">Car News By Brand</a></li>
<li id="menu-item-251430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251430"><a href="https://thenewswheel.com/topics/by-brand/ford/">Ford News</a></li>
<li id="menu-item-251431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251431"><a href="https://thenewswheel.com/topics/by-brand/chevy/">Chevrolet News</a></li>
<li id="menu-item-251432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-251432"><a href="https://thenewswheel.com/topics/by-brand/hyundai/">Hyundai News</a></li>
<li id="menu-item-1122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1122"><a href="https://thenewswheel.com/topics/celebrity/">Celebrity Car News</a></li>
<li id="menu-item-60168" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-60168"><a href="https://thenewswheel.com/topics/laugh-brake/">Just for Laughs</a></li>
<li id="menu-item-131937" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131937"><a href="https://thenewswheel.com/motorsports/">Motorsports</a></li>
<li id="menu-item-97419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97419"><a href="https://thenewswheel.com/topics/reviews/">Product Reviews</a></li>
</ul>
</div>
</div><!-- header -->
</div><!-- row --><div class="clearfix"></div>
<div id="content">
<div id="post-287577" class="entry single-rightsidebar post-287577 post type-post status-publish format-standard has-post-thumbnail hentry category-archives category-cars-in-film category-laugh-brake tag-80s-horror tag-bad-movie tag-emilio-estevez tag-killer-car-movie tag-maximum-overdrive tag-so-bad-its-good-movie tag-stephen-king">
<span class="post_topmeta">
<span class="entrydate pull-left"><i class="icon-calendar icon-white"></i>&nbsp;Added on April 16, 2021</span>
<span class="entryby metaitem pull-right"><i class="icon-user"></i>&nbsp;<a href="https://thenewswheel.com/author/ddimanna/">Daniel DiManna</a></span>
<span class="entrytag metaitem pull-right"><i class="icon-tags"></i>&nbsp;<a href="https://thenewswheel.com/tag/80s-horror/" rel="tag">80s horror</a> , <a href="https://thenewswheel.com/tag/bad-movie/" rel="tag">bad movie</a> , <a href="https://thenewswheel.com/tag/emilio-estevez/" rel="tag">Emilio Estevez</a> , <a href="https://thenewswheel.com/tag/killer-car-movie/" rel="tag">killer car movie</a> , <a href="https://thenewswheel.com/tag/maximum-overdrive/" rel="tag">Maximum Overdrive</a> , <a href="https://thenewswheel.com/tag/so-bad-its-good-movie/" rel="tag">so-bad-it's-good movie</a> , <a href="https://thenewswheel.com/tag/stephen-king/" rel="tag">Stephen King</a></span>		</span>
<div class="post_sharebuttons">
<div class="share-to-pinterest pull-right"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fthenewswheel.com%2Femilio-estevez-hilariously-rips-on-maximum-overdrive%2F&media=https%3A%2F%2Fthenewswheel.com%2Fwp-content%2Fuploads%2F2021%2F04%2Fscary_truck_at_night.jpg&description=Ah, Maximum Overdrive. This delirious, substance-fueled 1986 flick about killer vehicles has truly earned its cult status over the past 35 years. Generally regarded as one of the best so-bad-it’s-good flicks ever made, the film was directed by none other than the great Stephen King, adapting the story from his own novella. The results were [&hellip;]" class="pin-it-button" count-layout="horizontal"><img border="0" src="//assets.pinterest.com/images/PinExt.png" title="'Pin It" /></a></div>
<div class="share-to-google pull-right"><div class="g-plus" data-action="share" data-annotation="bubble"></div></div>
<div class="share-to-twitter pull-right"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://thenewswheel.com/emilio-estevez-hilariously-rips-on-maximum-overdrive/" data-text="Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’" data-lang="en"></a></div>
<div class="share-to-facebook pull-right"><div class="fb-like" data-href="https://thenewswheel.com/emilio-estevez-hilariously-rips-on-maximum-overdrive/" data-send="false" data-layout="button_count" data-width="80" data-show-faces="true"></div></div>
<div class=" metaitem"><i class="icon-comment"></i>No Comments</div>
<div class="clearfix"></div>
</div>		
<h1 class="entry-title">Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’</h1>
<div class="post_tools">	
<a rel="nofollow" href="#" class="fontsize-button fontSizeMinus pull-left">Decrease Font Size</a>
<a rel="nofollow" href="#" class="fontsize-button fontSizePlus pull-left">Increase Font Size</a>
<span class="tools_label pull-left">Text Size</span>
<a rel="nofollow" href="javascript:window.print()" class="print-this-page">Print This Page</a>
<a class="email-this-page" href="mailto:?subject=The%20News%20Wheel%20%3A%20Emilio%20Estevez%20Hilariously%20Rips%20on%20%E2%80%98Maximum%20Overdrive%E2%80%99&amp;body=I%20recommend%20this%20page%3A%20Emilio%20Estevez%20Hilariously%20Rips%20on%20%E2%80%98Maximum%20Overdrive%E2%80%99.%0AYou%20can%20read%20it%20on%3A%20https%3A%2F%2Fthenewswheel.com%2Femilio-estevez-hilariously-rips-on-maximum-overdrive%2F" title="Send by Email : Emilio Estevez Hilariously Rips on ‘Maximum Overdrive’">Send by Email</a>		</div>		
<div class="wp-block-image is-style-default"><figure class="aligncenter size-large"><a href="https://thenewswheel.com/?attachment_id=287618"><img loading="lazy" width="1000" height="576" src="https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night-1000x576.jpg" alt="A scary truck driving at night" class="wp-image-287618" srcset="https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night-1000x576.jpg 1000w, https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night-400x230.jpg 400w, https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night-768x442.jpg 768w, https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night-1024x590.jpg 1024w, https://thenewswheel.com/wp-content/uploads/2021/04/scary_truck_at_night.jpg 1250w" sizes="(max-width: 1000px) 100vw, 1000px" /></a><figcaption>Stephen King, killer cars, and lots of substance abuse. What could go wrong? Plenty, as it turns out&#8230;<br><sub><em>Photo: <a href="https://www.pxfuel.com/en/free-photo-owicn">Pxfuel</a> via <a href="https://creativecommons.org/licenses/publicdomain/">CC</a></em></sub></figcaption></figure></div>
<p>Ah, <em><a href="https://thenewswheel.com/killer-car-movies-maximum-overdrive-1986/">Maximum Overdrive</a></em>. This delirious, substance-fueled 1986 flick about killer vehicles has truly earned its cult status over the past 35 years. Generally regarded as one of the best so-bad-it’s-good flicks ever made, the film was directed by none other than the great Stephen King, adapting the story from his own novella. The results were patently ridiculous, and even the film’s star Emilio Estevez agrees.</p>
<hr class="wp-block-separator"/>
<p><strong>KBB Has Spoken:</strong> <a href="https://chevysenecafalls.billcramchevrolet.com/58/2021-chevrolet-trailblazer-named-one-of-kbb-coms-coolest-cars/">The 2021 Chevrolet Trailblazer is one cool SUV</a></p>
<hr class="wp-block-separator"/>
<h2>Emilio Estevez has regrets</h2>
<p>In a recent interview with <em><a href="https://www.vanityfair.com/hollywood/2021/03/emilio-estevez-mighty-ducks-interview">Vanity Fair</a></em>, Emilio Estevez sat down to discuss his long career. While most actors who’ve appeared in “bad” movies don’t particularly enjoy reminiscing about them, Estevez had plenty to say about a certain killer-car film.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- code from Primis - Thenewswheel - Thenewswheel.com VDU -->
<script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=101938&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembed18e6xilhupgy&vp_template=7044&subId=[SUBID_ENCODED]"></script>
<!-- code from Primis --></div>
<p>When asked about any movie roles he’s regretted taking over the years, Estevez immediately brought up <em>Maximum Overdrive</em>. “I’m not speaking out of class because he knows it’s a terrible movie,” he said in the interview, “but Stephen King often talks about his one directorial experience on <em>Maximum Overdrive</em>, which I was in. The few times that I’ve connected with him over the years, he’s like, &#8216;Can you forgive me for that?&#8217;”</p>
<p>Estevez’s initial interest in staring in a Stephen King film is certainly understandable. In the 1980s, Hollywood went “King crazy,” adapting a variety of King’s novels and short stories into movies. While most of these movies made their money back and several have become cinematic classics, King remained unsatisfied with most of them. By taking over directorial duties himself, he believed he could create the perfect adaptation of his work. He was very, very wrong.</p>
<p>Nevertheless, actors like Estevez were desperate to appear in any film associated with King. Unfortunately for Estevez, the King adaptation that will forever remain on his resume is <em>Maximum Overdrive</em>.</p>
<p>Estevez even recalls getting teased by his own mother for appearing in the film. &#8220;I think at one point my mom said, &#8216;Why’d you do that movie?&#8217; I said, &#8216;I wanted to work with Stephen King.&#8217; And she said, &#8216;Couldn’t you have helped him paint his house?&#8217;” Ouch.</p>
<hr class="wp-block-separator"/>
<p><strong>Great Used Buys:</strong> <a href="https://chevysenecafalls.billcramchevrolet.com/53/u-s-news-says-volt-tahoe-are-great-used-chevrolets-to-buy/">The Chevy Volt and Tahoe</a></p>
<hr class="wp-block-separator"/>
<p>Regardless of its quality, plenty of <a href="https://thenewswheel.com/film-adaptation-of-stephen-kings-from-a-buick-8-is-reportedly-in-the-works/">Stephen King</a> and horror fans still have a soft spot for <em>Maximum Overdrive</em>. It might be bad, but it’s certainly entertaining.</p>
<div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><img alt='' src='https://secure.gravatar.com/avatar/f89576dce5af9a64e2010aead84c6573?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/f89576dce5af9a64e2010aead84c6573?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' itemprop="image" loading='lazy'/></div><div class="saboxplugin-authorname"><a href="https://thenewswheel.com/author/ddimanna/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Daniel DiManna</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>Daniel DiManna hails from little Sylvania, Ohio. A graduate of Lourdes University with a degree in Fine Arts (which has thus far proven about as useful as a wet paper towel), Daniel’s hobbies/passions include film history, reading, fiction/non-fiction writing, sculpting, gaining weight, and adding more toys, posters, books, model kits, DVD’s, screen-used props, and other ephemera to his already shamefully monumental collection of Godzilla/movie monster memorabilia. His life goals include a return trip to Japan, getting a podcast off the ground, finishing his novel, and yes, buying even more monster toys. <a href="https://thenewswheel.com/author/ddimanna/">See more articles by Daniel.</a></p>
</div></div><div class="clearfix"></div></div><!-- AI CONTENT END 2 -->
<div class="clear"></div>		
</div><!-- /entry -->
<div id="disqus_thread"></div>
</div><!-- /content -->
<div id="sidebar" class="sidebar sidebar-right">
<div class="sidebarinner">
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-39" class="widget widget_html_javascript_adder"><div class="widgetinner">
<div class="hjawidget textwidget">
<br><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Single Post - 2 (thenewswheel.com) -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-3511135426281664"
data-ad-slot="4281288433"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div></div>
<!-- End - HTML Javascript Adder plugin v3.9 -->
<div class="clearfix"></div>
<div class="sidebar-right-bottomleft">
</div>	
<div class="sidebar-right-bottomright">
</div></div><!-- .sidebarinner --></div><!-- /sidebar -->
<div class="clearfix"></div>	<div id="bottom_ads" class="row">
<div class="span4">
</div>
<div class="span4">
</div>
<div class="span4 lastad">
</div>
</div>
<div id="footer_nav">
<ul class="nav_bottom menu">
<li class="footer_top"><a href="#top" title="The News Wheel">Top <strong>&uarr;</strong></a></li>
</ul>
</div><!-- #footer_nav -->
<div class="clearfix"></div>
<div id="footer">
<div class="row">
<div id="foo_widget1" class="span3">
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-40" class="widget widget_html_javascript_adder"><div class="widgetinner">
<div class="hjawidget textwidget">
<a href="https://thenewswheel.com/about-us/">About The News Wheel</a> &nbsp; &nbsp; <a href="https://thenewswheel.com/about-us/contact-the-news-wheel/">Contact Us</a> &nbsp; &nbsp; <a href="https://thenewswheel.com/about-us/the-news-wheel-automotive-writing-staff/">Our Staff</a> &nbsp; &nbsp; <a href="https://thenewswheel.com/topics/archives/">Archives</a> &nbsp;
&nbsp; <a href="https://thenewswheel.com/about-us/privacy-policy/">Privacy Policy</a> &nbsp;
</div>
</div></div>
<!-- End - HTML Javascript Adder plugin v3.9 -->
</div>
<div id="foo_widget2" class="span4">
</div>
<div id="foo_widget3" class="span5">
</div>
</div><!-- row -->
</div><!-- footer -->
<div class="clearfix"></div>
<div id="footer_data">
<div class="row">
<div id="footer-left-side" class="span6">
</div><!-- #site-info -->
<div id="footer-right-side" class="span6">
<a rel="nofollow" href="https://thenewswheel.com/wp-login.php">Log in</a> - 			
<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform">Powered by WordPress</a> - 
Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> &nbsp;
<!-- Start of StatCounter Code -->
<script>
<!--
var sc_project=9149954;
var sc_security="0716b4ab";
var sc_invisible=1;
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
//-->
</script>
<script type="text/javascript"
src="https://secure.statcounter.com/counter/counter.js"
async></script>		<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/9149954/0/0716b4ab/1/" alt="web analytics" /></a></div></noscript>
<!-- End of StatCounter Code -->
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TZB72K5"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div id="fb-root"></div>
<script type='text/javascript'>
<!--
(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
// -->
</script>
<script type='text/javascript'>
<!--
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
// -->
</script>
<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script>
<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js">
<!--
document.body.innerHTML = document.body.innerHTML.replace(/&amp;;/g, "a");
// -->
</script>
<script type="text/javascript">
<!--
(function() {
var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
po.src = 'https://apis.google.com/js/plusone.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
// -->
</script>
<style type="text/css">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</style><script type='text/javascript' src='https://thenewswheel.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thenewswheel"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thenewswheel.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.21' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"287577 https:\/\/thenewswheel.com\/?p=287577","disqusShortname":"thenewswheel","disqusTitle":"Emilio Estevez Hilariously Rips on \u2018Maximum Overdrive\u2019","disqusUrl":"https:\/\/thenewswheel.com\/emilio-estevez-hilariously-rips-on-maximum-overdrive\/","postId":"287577"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thenewswheel.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.21' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://thenewswheel.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202115.js' defer></script>
<script>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:9.5',blog:'55058821',post:'287577',tz:'-4',srv:'thenewswheel.com'} ]);
_stq.push([ 'clickTrackerInit', '55058821', '287577' ]);
</script>
</div> <!-- #footer-right-side -->
</div>
</div><!-- footer_data .row-->	
</div><!-- container (started in header.php) -->
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script> 
</body>
</html><!-- WP Fastest Cache file was created in 0.26923894882202 seconds, on 16-04-21 16:22:47 -->